Новое в Symfony 4.3: Устаревшие псевдонимы сервисов

Устаревание – это ключ к обещанной обратной совместимости, которое обеспечивает плавное обновление ваших проектов между минорными версиями (например, с 4.0 до 4.x). Для разработчиков приложений Symfony были добавлены возможности пометить как устаревшие службы, параметры конфигурации, шаблоны, блоков и макросов Twig.

В Symfony 4.3 вы также можете отказаться от псевдонимов служб. Когда псевдоним больше не должен использоваться в вашем приложении, определите его как устаревший с помощью опции deprecated в конфигурации:

# config/services.yaml
services:
    # ...

    app.mailer:
        alias: App\Mail\PhpMailer
        deprecated: true

Если этот псевдоним используется где-либо в вашем приложении, вы увидите общее сообщение об ошибке. Если вы предпочитаете настраивать это сообщение, определите его с помощью deprecated опции (единственное требование заключается в том, что бы в сообщение был параметр %alias_id%):

# config/services.yaml
services:
    # ...

    app.mailer:
        alias: App\Mail\PhpMailer
        deprecated: 'The "%alias_id%" service alias is deprecated.'

Комментариев нет

Добавить комментарий

Ваш e-mail не будет опубликован. Обязательные поля помечены *